mirror of
https://github.com/willemml/dotfiles.nix.git
synced 2025-04-04 00:03:29 +00:00
My dotfiles, this time with nix.
common | ||
home | ||
libvirt/vm | ||
nixos | ||
packages | ||
.envrc | ||
.gitattributes | ||
.gitignore | ||
flake.lock | ||
flake.nix | ||
LICENSE | ||
README.md |
My dotfiles using Nix. System configuration done using nix-darwin and NixOS. User configuration using home-manager. This repo is put together as a flake using flake-parts.
All Nix code in this repo is formatted using alejandra.
Usage
Switch both system (NixOS) and home:
nixos-rebuild switch --flake .
Switch system (nix-darwin):
darwin-rebuild switch --flake .
Update all inputs:
nix flake update --commit-lock-file
Update a single input:
nix flake lock --update-input nixpkgs --commit-lock-file
Format all nix files:
nix fmt
Enter the dev shell (if not using nix-direnv):
nix develop